Pokaż wyniki od 1 do 9 z 9
  1. #1
    Obserwator
    Dołączył
    August 09
    Postów
    6
    Siła Reputacji
    0


    Twoja ocena: Yes No

    Problem z ładowaniem grafiki przy wyświetlaniu strony

    Witajcie :-)
    Nie jestem fachowcem w tej dziedzinie ale nigdy takiego problemu nie miałem.
    Otóż strona ładuje się bez zarzutu, ale gdy na tym samym serwerze "zaparkowałem" domenę i skopiowałem pliki do nowego katalogu, wczytuje się (a raczej nie chce) bez plików jpg
    Co jest nie tak!? Przecież pliki, w tym też kod jest taki sam?:???:
    Pierwszy adres: www.meblefarmer.private.pl
    i drugi: www.farmermeble.pl
    Pozdrawiam :-)

  2. #2


    Twoja ocena: Yes No

    Jak ręcznie wszedłem na http://www.farmermeble.pl/img/tlo2.jpg to potem na stronie samo się ładowało... spróbuj wpisać pełną ścieżkę do pliku zamiast tylko relatywnej, albo taką samą ze slashem na początku '/'.

    Jak w dojazd kliknąłem prawym przyciskiem i dałem żeby pokazał obraz tła to dostałem:
    d1
    Forbidden
    You don't have permission to access /img/tlo.jpg on this server.

    0
    Musisz w tym przypadku chyba zmienić uprawnienia do pliku na serwerze.

  3. #3
    Obserwator
    Dołączył
    August 09
    Postów
    6
    Siła Reputacji
    0


    Twoja ocena: Yes No

    Dziękuję. Zaraz spróbuję coś zmienić...
    Pozdrawiam :-)

  4. #4
    Obserwator
    Dołączył
    August 09
    Postów
    6
    Siła Reputacji
    0


    Twoja ocena: Yes No

    Hmm... nie wiem co zrobić.
    Fragment kodu wygląda tak:
    <TABLE border="0" width="800" height="740" cellspacing="0" cellpadding="0" bgcolor="#FFFFFF"
    bordercolor="#FFFFFF" background="/img/tlo.jpg" id="table 1" style="border-collapse: collapse">
    i tu przed img/tlo.jpg dodałem slash
    Na serwerze wygląda to tak (załączam dwa pliki) ale nie wiem czy to w czymś pomoże.
    W tej sytuacji jak wyglądałaby pełna ścieżka?
    Pozdrawiam.
    Załączone Obrazki Załączone Obrazki

  5. #5


    Twoja ocena: Yes No

    Pełna ścieżka to razem z http, czyli tak jak w przeglądarkę byś wpisywał adres samego obrazka.

    Na mojej stronie w CSS musiałem na początku dodać '/'
    -> /index/sidebar_content.jpg
    Aby ścieżka była absolutna (od samego root'a strony, czyli od "pierwszego katalogu"), w przeciwnym razie nie ładowało tła.

    Tylko slasha dodaj na początku "ścieżki" do pliku bo wydaje się to dobrym rozwiązaniem, skoro u mnie w CSS poskutkowało

  6. #6
    Obserwator
    Dołączył
    August 09
    Postów
    6
    Siła Reputacji
    0


    Twoja ocena: Yes No

    Aha, dziękuję :-) działa. Ale co w tej sytuacji zrobić z tymi wszystkimi jpg-ami ? Jest ich tam ponad 150, a kod pisałem w html-u
    Bardzo dziekuję za pomoc.
    A może usunąć ten katalog z farmermeble.private.pl Chociaż to pewnie bez sensu...
    Pozdrawiam

  7. #7


    Twoja ocena: Yes No

    Na obrazku, który zamieściłeś masz uprawnienia, jest tam rw-r--r--, nadaj takie same obrazkom

  8. #8
    Obserwator
    Dołączył
    August 09
    Postów
    6
    Siła Reputacji
    0


    Twoja ocena: Yes No

    Sprawdziłem, wszystkie pliki mają takie same uprawnienia. W dodatku, są takie same jak te, które są w katalogu fermermeble.private.pl, a z niego strony ładują się bez problemów.
    Pzdr

  9. #9
    Obserwator
    Dołączył
    August 09
    Postów
    6
    Siła Reputacji
    0


    Twoja ocena: Yes No

    Zmieniłem darmowy serwer, na którym podpiąłem wykupioną domenę i wszystko poszło bez problemów. Strona się wczytuje. Zatem wina leżała po stronie poprzedniego serwera.
    Dziękuję za pomoc i pozdrawiam :-)

Informacje o temacie

Users Browsing this Thread

Aktualnie 1 użytkownik(ów) przegląda ten temat. (0 zarejestrowany(ch) oraz 1 gości)

Podobne wątki

  1. Odpowiedzi: 2
    Ostatni post / autor: 05-01-09, 18:32
  2. Problem z wyświetlaniem strony w mozilli
    By moondanu in forum HTML, XHTML, CSS, JS, AJAX
    Odpowiedzi: 6
    Ostatni post / autor: 14-11-08, 11:22
  3. Problem z otwieraniem strony
    By Selia in forum OPROGRAMOWANIE
    Odpowiedzi: 7
    Ostatni post / autor: 16-09-08, 16:21
  4. Niepożądane strony przy przeglądaniu internetu
    By marwika in forum Dostęp do internetu
    Odpowiedzi: 4
    Ostatni post / autor: 25-07-08, 12:50
  5. Odpowiedzi: 10
    Ostatni post / autor: 13-09-07, 16:05

Zakładki

Zakładki

Uprawnienia

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •  

Jak czytać DI?

Powered by  
ATMAN EcoSerwer